LinuxDevCenter.com
oreilly.comSafari Books Online.Conferences.

advertisement


Security Alerts

Remote Root Exploit in QPopper

06/11/2001

Welcome to Security Alerts, an overview of recent Unix and open-source security advisories.

In this column, we look at buffer overflows in the Solaris mail utility, Qpopper, and TIAtunnel; temporary-file race conditions in Imp, kmmodreg, and ispell; format-string vulnerabilities in GnuPG and exim; denial-of-service attacks against NetBSD and Fpf; and problems in OpenSSH, the Cisco Content Service Switch, and BestCrypt.

GnuPG

The GNU privacy guard, GnuPG, has a format-string vulnerability that can be used by an attacker to execute arbitrary code with the permissions of the user executing GnuPG. The use of the --batch parameter (often used when GnuPG is called by an email client) prevents the exploitation of this vulnerability.

It is recommended that users upgrade GnuPG to version 1.0.6.

NetBSD DOS

A vulnerability in NetBSD's IP stack can be attacked by sending a large number of fragmented IP packets. For each fragment that NetBSD receives it will create a reassembly queue that is maintained for 30 seconds. If an attacker quickly sends enough fragmented packets that each have a different IP identification field, the machine may stop communicating on the network. It has been reported that several automated exploits for this vulnerability have been distributed.

It is recommended that systems running NetBSD-current from before April 17, 2001, upgrade to the latest NetBSD-current. Systems running NetBSD 1.5.x dated before April 24, 2001, should upgrade to NetBSD 1.5.x dated after April 24, 2001. These new versions introduce a new sysctl variable net.inet.ip.maxfragpackets that is used to control the upper limit of reassembly queues.

Alerts this week:

GnuPG

NetBSD DOS

OpenSSH

Solaris mail

Imp

Cisco Content Service Switch

Fpf

HPUX kmmodreg

BestCrypt

Qpopper

exim

TIAtunnel

Red Hat's xinetd

ispell

VirtualCart Shopping Cart

OpenSSH

OpenSSH can be manipulated into deleting any file on the system that is named cookies. This vulnerability only affects OpenSSH clients that have X-forwarding enabled.

This vulnerability has been fixed in the OpenSSH CVS repository. Users of OpenSSH should watch for an updated release or compile a version from the CVS repository.

Solaris mail

There is a buffer overflow in the Solaris version of the /usr/bin/mail program that could be used by an attacker to gain the permissions of the mail group. It has been reported to affect the SPARC and X86 version of Solaris 2.6, 7, and 8.

Users should remove access to /usr/bin/mail from untrusted users until a patch from SUN has been installed.

Imp

Imp, a web-based email client, does not safely create its temporary files when uploading or viewing attachments. This vulnerability creates a race condition that, if exploited, may allow an attacker to overwrite arbitrary files writable by the user running the web server. This vulnerability affects version 1.2.4 but may also affect earlier versions.

Users of Imp should upgrade to version 1.2.5 or newer as soon as possible.

Cisco Content Service Switch

The Cisco Content Service Switch does not properly restrict access to its web management system allowing unauthenticated users access to secure data. This affects versions of Cisco WebNS earlier than 4.01B29s or 4.10B17s.

Users should upgrade as soon as possible to Cisco WebNS version 4.01B29s or 4.10B17s.

Pages: 1, 2

Next Pagearrow




Linux Online Certification

Linux/Unix System Administration Certificate Series
Linux/Unix System Administration Certificate Series — This course series targets both beginning and intermediate Linux/Unix users who want to acquire advanced system administration skills, and to back those skills up with a Certificate from the University of Illinois Office of Continuing Education.

Enroll today!


Linux Resources
  • Linux Online
  • The Linux FAQ
  • linux.java.net
  • Linux Kernel Archives
  • Kernel Traffic
  • DistroWatch.com


  • Sponsored by: